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Introduction

CuneiForm Features

CuneiForm represents the state of the art in powerful OCR software.    
The program supports a wide selection of desktop scanners.    It recognizes 
any scanned page, separates text from graphics, and converts images into 
text files for your favorite word processor, spreadsheet, or database 
applications.    CuneiForm's speed and accuracy are unmatched.    Our 
Character     Recognition   and Spell Checker make CuneiForm the most 
powerful and productive OCR software in the world.

CuneiForm recognizes English language characters, except certain 
stylized fonts like Old and Middle English, the Runic alphabet and forms of 
Gaelic.    The program recognizes all commonly used type fonts.    Fonts can 
be mixed on a page, even within a paragraph or a word.    You need not tell 
the program which fonts it must read.

CuneiForm can handle typeset documents, as well as those printed on 
letter-quality printers, near letter quality dot-matrix printers, ink-jet printers, 
laser printers and electric typewriters.    Both regular and proportional letter 
spacing are accepted.    The program can retain the original formatting, 
tabulation, and adjust itself to line spacings.    It can read bold and italicized 
letters, ligatures, underlined and multi-column text.    It automatically 
separates text and images and can accept complex page layouts.

CuneiForm can normally recognize first, second and even third 
generation photocopies but the error rate for recognition may increase on 
poor quality documents.    It can also read images scanned by other software 
products and handles both fine and standard faxes.    CuneiForm cannot read 
handwriting.

CuneiForm's Spelling Checker improves OCR accuracy by looking for 
mistakes in text recognition and highlighting them for your attention.    The 
Edit Window displays the recognized text, including the highlighted 
words, for you to edit.    Next to the Edit Window is a Zoom Window that 
magnifies the original scanned image so that you can see exactly what was 
in the original document.    You can inspect and correct any word in the 
recognized text using CuneiForm's simplified word processor.

CuneiForm lets you can scan now and save the scanned image as a 
TIFF file and run recognition later.    This way, you can scan multiple 
documents and avoid a log jam at the scanner.

CuneiForm has an array of file-saving options.    You can scan a series of



pages and the program can AutoSave the images, assigning each an 
incremental file name (Page1, Page2, etc.).    You can scan a page, and save it
first as an image file and then as a text file after running Recognize. The 
Define Template Zone feature allows selective recognition on specified 
portions of an image.

CuneiForm operates under MS Windows 3.1 and higher versions.    Its 
on-line Help follows the standard Windows conventions for help systems.    
So if you're already familiar with a Windows program, then you're familiar 
with our help system. 

Congratulations.    You've purchased a great productivity tool.    We 
thank you for choosing our product from a field of competing products.



CuneiForm's Main Screen

      CuneiForm's main screen consists of four areas:
Main Menu ,
Control Panel, 
Status Line , 

 
and the large viewing area in which the various windows are 
displayed :

Image Window,
Image Zoom Window,
Manual Layout Window

        and Recognized Text Window.



The CuneiForm Control Panel

CuneiForm's Control Panel in the top left portion of 
the viewing screen (see also descriptions of CuneiForm's 
Main Screen) consists of a column of six buttons.    When 
a control button becomes unavailable, its label is struck 
through, e.g. Last Image.

 The Control Panel buttons are:

    Scan & Recog 
    Open Image
    Scan & View
    Recognize
    Brightness
    Last Image



The Image Window, or Page View

The scanned image is for all practical purposes an exact photocopy of 
your original document.    When you aren't sure if recognized text 
corresponds to what is actually on the document, you have a perfect copy to 
look at right on the screen.    It's very useful to be able to make corrections, 
knowing that you are being faithful to the original content.

The right half of the screen displays the scanned image from a file or 
from the scanner (just after scanning and before text is recognized).    This 
image display is referred to as the Page View.    You can choose to view the 
image at one of the four levels of magnification listed under View in the 
main menu.    

The Page View appears on the screen right after CuneiForm obtains 
an image from a scanner or a file.    Page View (along with Edit and Zoom 
Windows) disappears after you save the recognized text.    You can restore 
the Page View in this case by clicking Last Image in the Control Panel (or 
by selecting Restore Last Image in the File menu).

To control magnification of the Page View image, go into the View 
pull-down menu.    Here you can select from Fit In Window, Actual Size, 
200% and 400% magnifications.    If the portion of the image you wish to 
inspect does not fall within the window at higher magnifications, use the 
scroll bars along the right side and bottom to adjust the view.

If you want to look at a particular section in the Page View more 
closely in the Zoom Window, simply click your cursor (which assumes the 
shape of a magnifying glass in Fit in Window and Actual Size settings) on 
that section.    The area will appear at the center of the Zoom Window.

If, after scanning a document, you need to use the Auto brightness 
feature, click on the text area CuneiForm should use to set Auto by in the 
Page View.    If a scanning problem exists, the Fit In Window setting for the
Page View lets you see the whole page to identify an area with an average 
brightness to select.

If you use Define Template Zone (^T) to run recognition on selected 
areas of the image, you must define the template zone within Page View.

See also descriptions of CuneiForm's Main Screen.



The Zoom Window

The purpose of the Zoom Window is to display portions of the 
scanned image at high magnification.    It usually appears on screen when it 
makes sense to use it.    If it isn't on screen and you want to call it up, click 
Zoom View in the View menu or type ^Z.    You can also control the 
magnification level for the image in the Zoom Window from within the 
View menu.    Select Actual Size, 200% or 400% magnification.

The position in which the Zoom Window appears on screen depends 
upon when it is invoked.    If you call it up by clicking the cursor on an image 
after using Scan & View or after opening an image file, it will appear at the 
bottom left of the screen.    When it comes up alongside the Edit Window 
after character recognition, its position depends on the screen layout you've 
chosen from the Window menu.

Another way to move the image within the Zoom Window is to use its
scrolling feature.    Press and hold the cursor somewhere within the window 
and slide it in any direction.    The image will scroll up, down, to either side as
well as diagonally.

See also descriptions of CuneiForm's Main Screen.



The Manual Layout Window 
The Manual Layout Window    is useful when the document you want 

to scan has a fairly complicated layout consisting of more than one column of
text and/or graphics.    Select Manual Layout Option from the Options 
menu with the cursor (or type <Alt> + O, then Y).    Notice that the word 
Layout now appears to the right in the status line.    The Manual Layout 
window will appear later after you scan a document (see also descriptions of 
CuneiForm's Main Screen).

After scanning, and in order to facilitate accurate recognition, 
CuneiForm automatically fragments and lays out a scanned image into 
blocks of what it sees as cohesive, meaningful blocks of text, like 
paragraphs.    A text block is simply a set of characters.    You can view them 
on the scanned image in the Manual Layout window.

Because the program bases its divisions on spacing, rather than 
contextual cues, it cannot really make perfect judgments about which text 
belongs together.    The Manual Layout window provides several methods 
for recreating the divisions between blocks when the automatic layout is 
inaccurate.    The Manual Layout option is designed strictly for correcting 
mistakes made in the automatic layout process prior to recognition.

You would want to use it when the page you're scanning has a 
particularly complex layout, with text interrupted by graphics, hand-written 
notes, data tables, etc.    If you depend entirely upon automatic layout before
text recognition, you might end up spending a lot of time editing and 
deleting portions that you could have excluded using Manual Layout.

The Manual Layout window consists of an image screen with a long 
column of buttons aligned along its left side.    The page image that appears 
in the screen will be quite small.    To examine its contents more closely, click 
once on Zoom (or type Z) and then click the arrow cursor on the portion of 
the image you want to see magnified.    Click once on UnZoom (or type N) to
return to the full page layout view.

Other conventional items on the button column are Undo and Redo, 
which allow you to go back one step to reverse the last action you 
performed.

Say that, at the center of the page you're about to scan, there is a 
table with several rows and columns of data.    Using automatic layout, 
CuneiForm might fragment that table into many blocks that would be 
unintelligible after recognition is run.



Extract lets you delineate a block that includes all the various pieces 
of the table so they are merged into one block.    To do this, click once on 
Extract (or type C) and draw a box around the selected area of the image by
clicking and dragging.    This will create a new text box that includes all the 
table components.    Now when you run recognition, the contents of this new 
block will be treated as a unit.    If you want to exclude the table altogether, 
just select the new block with the arrow cursor and click once on the Delete 
button (or type L).

The Manual Layout window offers three additional methods for 
correcting layout errors: Split Horz, Split Vert, Merge and Delete.

For example, say you have two columns of text arranged on the 
scanned document, but CuneiForm doesn't see this.    Instead, it combines 
the two column segments into one block.    Because this could cause 
recognition problems later, you'll want to recreate the blocks to separate the 
columns.

To make the separation, click on Split Vert (or type S) on the left side 
of the Manual Layout window.    Next, place your cursor on the image where
you want the text division to start, and click and hold on the mouse button.    
Drag to the point where the division should end and release the button.    
CuneiForm will divide the blocks vertically into two blocks of text.    The Split 
Horz item performs the same function for text which should be separated 
horizontally.

In some cases, CuneiForm may fragment the image so that text which 
should flow together is divided.    To correct this division, first click once on 
each of the blocks you wish to unite and the click Merge in the button panel 
(or type M).    The two segments will be combined into one block.

If you want to exclude a block of text from recognition, click on it with 
the cursor and click once on Delete (or type L).    You can select multiple 
items for deletion by clicking on them sequentially, or select just one at a 
time.    (For those of you working on a color monitor, the rectangles 
surrounding blocks of text change from red to green when you select them.)

When you are satisfied with the layout of the scanned image, click 
Done (or type D).    This will initiate character recognition based on your new
manual layout.



The Edit Window

The Edit Window contains the results of character recognition. After 
character recognition, the Edit Window appears and obscures the Page 
View image.    The text you choose in the Edit Window synchronizes with 
the image in the Zoom Window.    When you move your cursor in the Edit 
Window, the image displayed in the Zoom Window shifts to correspond to 
new the cursor position and the image of the character selected is 
highlighted.

If the recognized text differs from the corresponding image, you can fix
any mistakes made in the recognition process and edit text if you wish. The 
Edit Menu options and Edit Window Button Bar at the top of the Edit 
Window help you clean up recognized text. However, you may prefer to edit
text from within your word processing program.    

If you have difficulty reading the recognized text as it appears in the 
Edit Window, adjust character size by selecting the Editor Settings/Font 
Size option from the View menu.    This option becomes available 
(unghosted) only after you run recognition on an image.

The Font Size box offers you a choice of Small, Medium, and Large 
fonts for displaying recognized text.    Click inside the circle to the left of your 
selection and click OK to set the selection (or Cancel to revert to a Small 
font).    The font size of the recognized text in the Edit Window will change 
accordingly.

When you've completed your inspection and made all corrections, save
your work by clicking on the Save As... or Append To... button in the Edit 
Window Button Bar (or select equivalent items in the File pull-down menu).



The Edit Window Button Bar
Across the top of the Edit Window, just below the heading, is a button

bar that contains five options:    Close, Save As, Append to, Next Suspect
and Validate Word.

Click on the Close button to close the Edit Window.    If you haven't 
saved the recognition results, a message box appears on screen, asking you 
whether or not you wish to close the window without saving the results .    

The Save As button is equivalent to the Save Text option beneath 
File in the main menu.    The dialog box labeled Save Recognition Results 
appears when you click on this button.    Select a directory and specify a file 
name for the recognized text you wish to save and click on Save to execute 
the action.

Append to performs the same function as Append Text under File in
the main menu.    When you press this button, the dialog box labeled 
Append Recognition Results appears.    Select a file to which you want the
current recognition results appended and click Append to execute the 
action.

The button labeled Next Suspect is equivalent to the Next Suspect 
option under Edit in the main menu.    Click on it to advance the cursor to the
first character of the next suspect word highlighted in the recognized text.

The Validate Word button performs the same function as the Validate
Word selection under Edit in the main menu.    Click on it to add the currently
selected word of the recognized text to the user dictionary, so that 
CuneiForm won't highlight it as suspect when you subsequently run 
recognition.



The CuneiForm Status Line

 127 | dpi 300 | INS | 2:2 | English | Spell | Dict:user.usv | Layout | 1 Col | Dots |
        A                  B                  C              D                  E                    F                                    G                     
H                        I                    J              K

The status line at the bottom of CuneiForms viewing screen contains 
information on values for various options set from within the main menu.

A. The brightness setting, 127 in this illustration, is shown at the left end 
of the line.

B. Next, the resolution setting is displayed (B). Here its 300 dpi, or 300 
dots per inch.

C. To the right of the resolution setting, the box labeled C will either contain
INS, for insert, or OVR for overwrite. INS means that you will be 
inserting text into existing text in Edit Window. OVR indicates that 
youll be overwriting existing text as you type new characters in.

D. The section labeled D indicates cursor position. Here, the 2:2 shows that 
the cursor is on the second column of the second line of text in Edit 
Window.

E. The area labelled E shows which language character recognition is set 
for (see Set Language command). 

F. If youve selected Spell Check from the Options menu, Spell will appear
in the area labeled F.    If Spell Check is not selected, this area will 
remain empty.

G. If youve loaded a User Dictionary from the File menu, the dictionary 
file name will appear in the box labeled G.

H. The section of the status line labeled H will contain the word Layout if 
you have selected Manual Layout from the Options menu. Otherwise, 
it will be empty.

I. When you select the Single Column layout mode from the Options 
menu, the area labeled I will display 1 Col but will otherwise be empty.

J. DOTs on the right end of the status line (J) indicates that youve selected 
Dot Matrix in the Options menu. Activating this option enables 
CuneiForm to recognize text generated by dot matrix printers.

K. If youre reading a TIFF file in standard fax mode, the last field of the 
status line tells you whether resolution is 100 or 200 dpi.



The Main Menu

CuneiForms main menu at the top of the Main Screen contains the 
following seven items, each with its own pull-down menu:

    File Menu - opening files, saving files, exiting from the program
    Edit Menu - operations in Text Window
    Actions Menu - main user actions
    Options Menu - options for recognition process
    View Menu - view and zoom scales
    Window Menu - layout of CuneiForm windows
    Help Menu - getting help



The File Menu

Click once on File in the Main Menu (or type <Alt> + F) to invoke the 
pull-down menu illustrated here.

    Open Image - read image from file
    Restore Last Image - retrieve last processed image
    Save Image - save image in a file
    Open CTC native file - open file with earlier recognized text
    Save Text - save recognized text in a file
    Append Text - add your recognized text to the end of an existing 
text file
    Select TWAIN Source - choose a TWAIN source for the image
    Acquire image - access the image from the TWAIN source
    User Dictionary - working with the user dictionary
    Recognition engine - load or unload recognition engine
    Exit - exit from CuneiForm



The Open Image button in the Control Panel and Open Image menu item

The Open Image item in the File menu performs exactly the same 
function as the Open Image button on CuneiForms Control Panel.    It lets 
you open a previously saved image.    When you click on it once (or type ^O) 
the Open Image window will appear.    Click once on the name of the 
directory containing the file in the Directories scrolling list.    Next, either 
type in the file name in the Filename text field or double-click on a name 
listed below in the Files box.



The Last Image button in the Control Panel and Restore Last Image 
menu item

The bottom button in the Control Panel is Last Image.    Click this 
button to retrieve the last image that was displayed on the screen during the
current work session.    It will appear regardless of whether you saved the 
image or not.    You can also bring up the last image by selecting Restore 
Last Image from the File menu.

Click once on Restore Last Image (or type ^L) to call up the last 
image that you had on the screen.    This command is useful when you're 
working with documents that must be broken into several small files using 
Define Template Zone (see the Action menu item ).    Even if you haven't 
saved it, CuneiForm holds the last scanned image in memory so that you can
quickly retrieve it and select another area to recognize.

If you don't save the recognition results and you close the window 
containing recognized text (the Edit Window), you can select Restore Last
Image to call the image up again.    CuneiForm holds the image in memory 
until you open another file or scan another page.



The Save Image menu item

If you don't want to run recognition on a scanned page, you can save 
the image for recognition later.    Click Save Image in the File pull-down 
menu (or type <Alt> + F, then I).    The Save Image window will appear.

Using standard Windows procedures, specify the drive and directory to 
save to, and type the file name in the box provided.

The Image Format box at the bottom of the window contains a list of 
image formats from which to choose.    Uncompressed image files require 
about 1 megabyte per page while compressed files are much smaller.    We 
recommend using TIFF Group 4 because it provides the most compression.

The last format used becomes the default selection the next time an 
image is saved.

Click OK to save the scanned image (or click Cancel).



The Open CTC native file menu item 

Click once on Open CTC native file in the File menu to call up the 
Open Text dialog box containing a list of files in CTC native format 
(saved earlier after recognition). When you choose a file, CuneiForm tries 
to open the text file and the corresponding image file (with the 
extension .TIF). If it opens both files successfully, CuneiForm proceeds as if
recognition was just completed. You can now edit the recognized text 
referring to the image.

If CuneiForm cant open the image file, the Open Image dialog box 
appears. You can choose another image or click Cancel.    If you select 
Cancel, CuneiForm lets you edit recognized text but doesnt retrieve an 
image.



The Save Text menu item and Save As button in Edit Window's Button
Bar

Click on the Save As button (at the top of the Edit Window) or click 
on Save Text in the File pull-down menu (or type <Alt> + F, then T) after 
you have run recognition on a scanned image and want to save the results 
as a text file.    The window labeled Save Recognition Results    appears on 
screen.

Select the directory you want to store your file in from the Directories
list, and choose the file format from the Document Format list (Smart ASCII
format, ASCII format, RTF    format, CTC native format).    Then, next to 
Filename, replace the asterisk with the name of the new file and click Save 
to complete the operation (or Cancel to abort the save).

The Unrecognized Character box lets you choose a character that 
CuneiForm will use to represent all unrecognized letters. 



The Append Text menu item and Append To button in Edit Window's
Button Bar

 
Click on the Append to button (at the top of the Edit Window) or 

click on Append Text in the File pull-down menu (or type <Alt> + F, then 
P) to add recognized text to the end of an existing text file.    The Append 
window will appear on screen.

Select the directory containing the file to which you wish the current 
recognition results appended, choose the file format from the Document 
Format list (Smart ASCII format, ASCII format or RTF format).    In the 
Filename box, enter the name of the file.    Next, click on the Append 
button.    The current recognized text will now be a part of the file you 
specified.

The Unrecognized Character box lets you choose a character that 
CuneiForm will use to represent all unrecognized letters. 



The Select TWAIN Source menu item 

CuneiForm is a TWAIN-compliant host application, which means that 
you can import images produced using the TWAIN application programming 
interface.    The Select Source option lets you choose a source for the 
image.      Single-click on Select Source in the File menu (or type <Alt> + 
F, then S) to call up the Select Source window.

To choose an item from the Sources list, either click on it once and 
press the Select button, or simply double-click on your choice.    Either way, 
the window will disappear.    The next step will involve the Acquire option in 
the File pull-down menu.



The Acquire TWAIN Image menu item 

Click on Acquire Image in the File menu (<Alt> + F, then A) to 
access the image from the TWAIN source you selected.    If you have 
requested TWAIN dialog, a window will appear with the name of the specified
source scanner at the top.    The contents of the window depend upon the 
source scanner you select.

The window will contain fields into which you can enter values for a 
number of parameters, which may include size of the image, scan mode, 
brightness, contrast, type of image, etc.

When you are satisfied with the settings, click the Scan button in the 
window.    The imported image will appear in Page View on the CuneiForm 
screen.    Now you can save it as an image file, run recognition, save the 
results as a text file, and generally treat it just as you would any image 
produced on your own scanner.



The User Dictionary menu item 

The User Dictionary option lets you load, unload, import and export 
dictionaries you've put together yourself.    If you work in a highly technical 
field you probably need a dictionary that includes words that would not 
appear in a non-technical dictionary.

After putting an image through text recognition, you can select words 
in the text for validation (see Validate Word button and menu item).    Youll 
have the option of saving these in a user dictionary or as text.

A user dictionary will prevent the program from constantly selecting 
out words (like company names or product names) unless they are actually 
misspelled.    You can update your dictionary at the end of each session so 
that it suits your needs.

To turn your user dictionary on or off, click User Dictionary in the File
pull-down menu (<Alt> + F, then D).    Select Load or Unload to activate or
deactivate your dictionary.

If, over time, youve created a dictionary in your word processor, or if 
you just have a list of words you want to include in your CuneiForm 
dictionary, you can import it into CuneiForm by selecting Import from the 
User Dictionary pull-down menu.    Likewise, if you would like to export a 
dictionary created in CuneiForm to another application, select Export.



The Recognition Engine pull-down menu

Click on Recognition Engine in the File menu (<Alt> + F, then R).
The Recognition Engine option lets you load and unload CuneiForms 

recognition engine as needed so that you can optimize time and memory 
usage. By default, the engine is loaded at startup. It occupies about 4.5MB of
RAM. If the engine was not loaded at startup (i.e., if you have deselected 
Load on start), it will be loaded automatically when you request 
recognition. 



The Exit menu item

Select Exit from the File pull-down menu (or type <Alt> + F4) to exit 
CuneiForm.



The Edit Menu

Click Edit in the Main Menu (<Alt> + E) to invoke the pull-down 
menu, which consists of the following items:

    Next suspect - go to next suspicious word (suspect)
    Prev suspect - go to previous suspicious word
    Show suspects - show suspicious word
    Search - search for string of characters in recognized text
    Search Next - repeat previous search
    Validate word - make suspect word legal and insert it into list of validated
words
    Invalidate word - make word suspect and remove it from list of validated 
words



The Next Suspect menu item and button at the top of the Edit Window    

If CuneiForm comes across a word or character it can't recognize, it will
highlight it in the Edit Window as suspect.    After you've examined and/or 
edited each highlighted word, click on Next Suspect (or hit <Tab>) to 
advance through the text to the next word CuneiForm finds suspect.    When 
you click on Next Suspect after having advanced through all suspect words,
CuneiForm sounds a beep to let you know that you've seen all the suspects. 

Click on the Prev Suspect option in the Edit menu or type <Shift> +
<Tab> to return to the previous suspect.

The Next Suspect option in the Edit menu is equivalent to the Next 
Suspect button in the Edit Window menu.



The Show Suspects menu item 

Select the Show Suspects option in the Edit menu if you want the 
characters    or words CuneiForm suspects are incorrect to be highlighted in 
the Edit Window after running text recognition.    This option is either turned
on or off.    A checkmark appears to the left of Show Suspects in the Edit 
pull-down menu if it is active.    If you leave this option off, no text will be 
highlighted in the Edit Window.



The Search menu item 

Use Search to look for a string of characters within recognized text.    
Click on the Search option in the Edit menu (<Alt> + E, then S) to call up 
the Search window. Enter the character string to look for in the box labeled 
Search for.    If you want the search to be case-sensitive, click inside the 
Case Sensitive box.

If you want CuneiForm to look through text that comes after your 
current cursor location, click inside the Forward box.    If you leave the 
Forward box unchecked, CuneiForm will conduct its search back through 
text from your starting point to the beginning of the document.



The Search Next menu item 

Selecting Search Next in the Edit menu (or pressing F3) instructs 
CuneiForm to find the next occurrence of a character string specified for 
using Search.    When all occurrences have been found, CuneiForm will 
sound a beep when you again choose Search Next. 



The Validate Word menu item and button at the top of    Edit Window    

When CuneiForm encounters a suspect. such as a company name or 
product name, you can select Validate word from the Edit menu (^W or 
<Alt> + E, then V) or use the Validate Word button to add that word to 
your user dictionary (or save it as text if you wish).    When it next runs 
recognition, CuneiForm will not highlight the validated word as suspect 
(unless your user dictionary isn't loaded).



The Invalidate word    menu item 

If, during the course of editing, you have selected a word for validation 
and inclusion in your user dictionary, but later decide you don't want it 
validated, use the Invalidate word command.    Click your cursor on one of 
the characters in the word and click on Invalidate word in the Edit pull-
down menu (or type ^W).



The Close button at the top of the Edit Window

If you close a scanned document before saving it, a message box will 
remind you that the recognition results are not saved and ask if you want to 
save them before closing the editor.    You can either save the results, close 
without saving, or cancel the operation altogether.

When you close without saving by clicking Yes in the message window,
the document closes and CuneiForm's main screen appears.    When you click
No, the message box disappears.    You can now choose Save Text from the 
File menu to store your recognized text.

If, while editing the text, you selected words for validation (see 
Validate Word ) the List of Words box will appear when you attempt to 
close. This box lists the words you selected to validate during your edit.    You 
can save these in the user dictionary or save them as text.

To include these words in your user dictionary, click on the Dict button 
in the Save as box.    A new window labeled Save as User Dictionary 
comes up.    Specify a directory in the Directories list.    Next, in the box next
to FileName, replace the asterisk with a name for your user dictionary.    
Press Return or click on OK to complete the save.



The Actions Menu
Click Actions in the Main Menu (<Alt> + A) to invoke CuneiForm's 

Actions menu.    Use the following commands to control scanning and 
character recognition:

    Batch scanning
    Batch recognition
    Scan and View
    Set Language
    Recognize
    Define Template Zone
    Rotate
    Select Scanner
    Set resolution
    Set Brightness



The Batch scanning menu item 

Select Batch Scanning from the Actions menu (<Alt> + A, then A) 
to scan a series of pages.    The Batch scanning window appears.

The Batch scanning window contains five main fields: Options, Save
Pages, Create Document, Modify and Output Format. You can combine 
these settings in various ways, depending on whether your scanner has a 
feeder, you want to run recognition before saving, you want to control the 
recognition template, and so on. Each combination you create will change 
the processing sequence in some way. Youll probably find that there are two 
or three simple setting combinations that you tend to use repeatedly in 
batch scanning.

The Options box settings controls the general flow of the processing.

1. Pause between pages:  Check this item if your scanner doesnt have a 
sheet feeder and you need to load pages separately. When you initiate 
batch scanning, you will see the prompt Do you want to continue with the 
next page? This message will appear after you finish processing each 
page. Click Yes to start the series of scans. (Click No to terminate batch 
scanning entirely.) Place the first document of the series into the scanner 
and click OK. (Press Cancel to terminate batch scanning.)

If you dont check Pause between pages, youll see the message Put 
pages into scanner or Cancel. when you first initiate scanning.    After this, 
CuneiForm will begin scanning the next document automatically after you 
finish with the previous one.

2. Deferred recognition: Check this item if you want to postpone 
recognition until all pages have been scanned. Otherwise, each page will 
be recognized immediately after being scanned.

3. Stop on warnings: Check here if you wish to have the option of 
interrupting batch processing whenever an error or a suspicious condition 
(such as File already exists) occurs. If you opt to interrupt the process 
under these circumstances, the program will ask you whether to 
completely stop or to resume batch processing.

4. Define template:  Check this item if you want to avoid recognizing 
extraneous materials like advertisements, cartoons, portions of other 
articles on the same page, etc. Youll be prompted to Select the area to 
recognize at the Page View or press Cancel after each image is scanned. 
Press and drag the left mouse button to outline the area to recognize. 
Next, youll be asked to Confirm the chosen template. Click Yes to confirm 
your template choice. Recognition will begin. Click No if you want to 



redraw the template.

If you leave Define template unchecked, CuneiForm will automatically 
run recognition of the full page after each scan. The results will appear in 
the Edit Window, alongside the Zoom Window.

5. Recognize:    Select this item if you want recognition run automatically 
after each document is scanned. Dont select it if you want to quickly scan 
a series of documents for recognition later ( see also Batch recognition).

6. Run editor:    This item lets you edit recognized text before saving it. If its
left unchecked, recognized text will remain unedited.

In the Save pages box, indicate whether to save scanned images 
(Image), save text after recognition (Text), or both.    The Initial name 
window lets you set the file name for the first page to be saved. When the 
Batch scanning window appears for the first time, type a name for the file 
in the Initial name field. The filename, with an appended number, will be 
increased an increment each time a new page is stored. When the Batch 
scanning window appears at the start of subsequent scans, the Initial 
name field will already contain the name you entered for the batch of 
documents last scanned. 

 The Browse button calls up the    Save Image or Save Text dialog 
box.

The Create document box controls the destination of recognized 
pages. If you click None, no documents will be created. After recognition, 
each page will be stored separately, according to the Save pages settings.

If you choose Single, all pages will be appended to a single document 
whose name you enter in the adjacent Name box. Click Browse to bring up 
the Append Recognition Results dialog box. Click Multi to indicate that 
the pages in the scanner are separated into individual documents by empty 
pages.    Enter the name of the first document in the Name box (or use the 
Browse feature).    Subsequent documents will be assigned names 
automatically by numerically incrementing the name of the first document.

NOTE: The Document mode is not available when saving pages in 
the CTC native format.

The Modify box lets you modify names of saved images and/or 
recognized pages. If you click on Image name or Text name, the 
appropriate dialog boxes will appear at specific processing stages (after 
scanning, recognition or editing).



The Output format box lets you specify formats for saving images 
(uncompressed or compressed Group 4) and/or recognized text (Smart ASCII 
format, ASCII format, RTF    format, CTC native format).

On the right side of the window are the command buttons Start, 
Cancel, Store, Restore and Help. Click Store to retain your current batch 
processing settings; click Restore to obtain the settings previously saved. 
When youre satisfied with your settings, click Start to initiate batch 
processing. As batch scanning begins, a large STOP button appears on 
screen so that you can interrupt batch processing at any time.

The Progress Monitor window appears on screen during recognition 
and the recognition results are presented in the Edit Window. The program 
will use the file name specified in the Initial filename space in the Save 
options window to name your file.



The Batch Recognition menu item 

Select Batch recognition from the Actions (<Alt> + A, then I) 
menu to organize batch processing of scanned pages. The Batch 
recognition window appears on screen.

The controls in the Options, Modify and Result boxes are identical in 
function to the corresponding controls in the Batch scanning window. 
Select image files to be processed from those listed in the Image files box.

To add files to the list, click the Add button. The Open Image dialog 
box comes up with its standard Windows choices.    To add a file to the 
selected set, press <Ctrl> and click on the filename.    To add several files, 
press <Shift> and click on the file names. Click OK to add all highlighted 
files to the Image files box in the Batch recognition dialog box.

You can delete one or more files by highlighting their names and then 
clicking the Delete button. You can also deselect all selected filenames by 
clicking Clear All.



The Scan & View button and Scan & View menu item    

If you want to scan a document and view it without first going through 
character recognition, select Scan & View from the Actions menu (^S) or 
Select Scan & View from the Control Panel.    Scanning will begin 
immediately and a Page View of the scanned image will appear in the right 
half of the viewing area. 

See also Scan & Recog button.



The Scan & Recog Button

Click once on the top button, Scan & Recog, in the Control Panel to 
initiate scanning and automatic recognition of a document.    You'll want to 
use Scan & Recog when you're fairly certain that your document's layout is 
straightforward and won't complicate text recognition.    (For more complex 
layouts, Scan & View is a more useful operation.)

When you first activate Scan & Recog, a message box appears to let 
you know that scanning is in process.    Next, the Progress Monitor box 
shows which phase of character recognition is underway as well as the total 
percentage of recognition completed.

Selecting the    Scan & Recog button is equivalent to executing Scan 
& View and then Recognize, without performing any intermediate actions.



The Set Language menu item 

CuneiForm can recognize characters for different languages. The 
Assign Language window appears when you select Set Language from 
the Actions menu (type <Alt> + A, then L).

Click on the arrow, obtain the list of available languages, choose the 
language in which your document is written and click OK. This will load 
CuneiForms dictionary for that language so that words and special characters
will be processed properly during recognition.



The Recognize Button and    Recognize menu item 

Use Recognize when you want to run character recognition after 
executing Scan & View or after retrieving a stored image file.

The Recognize command in the Actions menu (^R) is equivalent to 
the Recognize button in the Control Panel.    Select it to run recognition on 
an image.



The Define Template Zone menu item 

If you wish to run recognition on only a portion of an image, select 
Define Template Zone from the Actions pull-down menu (^T).    A window 
will appear, prompting you to Select the area to recognize...    Using the left 
mouse button, press and drag to create a box around the portion of the 
image to be recognized.    Then click on Recognize in the Control Panel, or 
select it from the Actions menu.    CuneiForm will run recognition on just that
portion of text you've outlined. 



The Rotate menu item 

The Rotate command becomes available when a scanned image 
appears on screen after you've used Scan & View, opened an existing 
image file, or restored the last image that was on screen.    Select Rotate 
from the Actions menu (or type <Alt> + A, then O) to invoke the pull-down
menu.    

To rotate the scanned image 90 degrees to the left, click Left (or type 
L).    To rotate the image 90 degrees to the right, click Right (type R).    To 
rotate it 180 degrees, click Upside down (type U).



The Select Scanner menu item 

When you first open the CuneiForm program, Select Scanner is 
probably the first command you'll use.

1. Select Actions from the CuneiForm main menu at the top of the screen 
(or type in <Alt> + A).

2. Click once on the Select Scanner item in the Actions pull-down menu 
(or type <Alt> + A, followed by E).    The Scanner Setup Window will 
appear.

3. Choose one of the two available systems--ISIS or TWAIN--and click on the 
Scanner button. This will call up either the Scanner Selection window (for
ISIS) or the Select Source window (for TWAIN).

4. Find your model in the scrolling list, click on it to highlight it, and click on 
OK. PLEASE NOTE: If yours is a "Limited Edition" CuneiForm package, your
program will not support the full ranger of scanners. Contact CTC for 
information on updating your program.

5. Now, click on Setup. In the ISIS system you may be asked to specify 
parameters like paper size, scan speed, port address, etc. In the TWAIN 
Setup dialog window you can choose either TWAIN's Native Transfer mode
or Buffered Transfer mode. Because it consumes less RAM, we recommend
the buffered mode.    You can also activate the TWAIN dialog at every scan 
session. The dialog form and controlled features depend on the TWAIN 
source.    Please consult your scanner manual.    If you choose not to 
activate the TWAINs dialog, CuneiForm will determine all settings for each 
scanning session.

6. After entering these settings, click OK to confirm the operation (or click 
Cancel). The name of the scanner you selected will now appear in the 
Scanner Setup window.



The Set Resolution menu item 

Click on Set Resolution in the Action pull-down menu (^D) to call up
the Select Scanner Resolution window.

Select a 200, 300, or 400 dpi (dots per inch) resolution setting. If your 
scanner model cant scan at the highest resolutions, youll be instructed to 
lower the setting.



The Brightness button and Set Brightness menu item 

The Brightness button lets you set an optimum level of brightness for
scanning documents.    CuneiForm offers 255 graded brightness settings (0-
255).    The default setting is 127, an average setting.

The last command in the Actions pull-down menu, Set Brightness, is
equivalent to the Brightness button in the Control Panel.    Click on it once 
(or type ^B) and the Select Brightness window will appear.

If you're getting a lot of character recognition errors because the 
scanned image is too light, select a setting in the lower range of values and 
rescan the document.    If the image is too dark, set a value from the upper 
end of the range.    You can set the brightness levels by dragging the slidebar
left or right across the brightness scale.    The brightness level you select 
appears in the text box to the right.    You can also simply type a value into 
the text box.

Another alternative is to use the Auto brightness setting. 



The Auto brightness setting is available only when you have just 
scanned a document.    Otherwise, the button is ghosted in the Select 
Brightness window.    Use the Auto button when the results of your current 
scan are unacceptable.

Click on Auto in the Select Brightness box.    A small dialog box will 
come up, instructing you to Click the left mouse button where you want 
brightness to be set or press Cancel."

When you move the cursor onto the image, it's transformed into a 
lightbulb icon with crosshairs next to it.    Position the crosshairs on a portion 
of the image that has an average character density or darkness and click on 
it.    Don't choose an area with dark or light extremes.

The Auto brightness function will scan the selected portion of the 
image to define an overall brightness setting.    Next, you'll be asked if you 
want the page scanned using the new brightness setting.    Click Yes and the 
document will be rescanned.    The quality of the scanning results will depend
upon whether the area you chose to define brightness was actually 
representative of average brightness on the document. 

Before scanning again, look for the value of the new setting in left 
hand corner of the status line at the bottom of the screen.    If the value 
differs from the previous brightness setting by only 10 points or so, don't 
bother to scan again.    Instead, try setting the value manually or select a 
new area for defining the brightness setting using the Auto button.

Once set, the Auto value will stay in effect until you change it, either 
manually or by using Auto again.    Once you close the CuneiForm program 
or turn off the computer, the brightness setting will revert to the default 
value of 127. 

NOTE:    To use Auto brightness setting with some scanners that have
an auto sheet feeder, you'll have to manually place the page in the scanner 
and not in the feeder. Also, make sure that nothing is loaded in the feeder 
until after you set Auto.



The Options Menu
Click Options in the Main Menu (<Alt> + O) to invoke the Options 

pull-down menu.  Its five items help you control document scanning, layout 
and recognition.

When each of these items is selected, a checkmark appears to the left 
of it in the Options pull-down menu and the status line shows that it's 
activated.    The options are as follows:

    Manual Layout - turn manual layout on/off
    Single Column - enforce one column on/off
    Spell Check - turn spelling checker on/off
    Adaptive Scan - adaptive scan flag on/off
    Dot Matrix - dot matrix flag on/off
    Page Orientation - rotating of loaded page



The Manual Layout menu item

The Manual Layout option is useful when the document you want to 
scan has a fairly complicated layout consisting of more than one column of 
text and/or graphics.    Select this option from the Options menu with the 
cursor (or type <Alt> + O, then Y).    Notice that the word Layout now 
appears to the right in the status line.    The Manual Layout window will 
appear later after you scan a document and select recognition.



The Single Column menu item 

Click on the Single Column option (or <Alt> + O, then I) in the 
Options menu to instruct CuneiForm to treat all characters on a scanned 
image as a single column of text.    Notice that when you select this item, the 
character string 1 Col appears in the right half of the status line.

Make sure this option is turned off when you scan a page containing 
more than one column of text.    Otherwise, your character recognition results
will be a jumbled mess.



The Spell Check menu item 

If you select Spell Check from the Options pull-down menu (<Alt> +
O, then P), CuneiForm will highlight questionable words for you to examine 
after running recognition on a document. Please note that, when you instruct
CuneiForm to run recognition on foreign languages for which it has no 
dictionaries installed, the Spell Check option is ghosted (unavailable) in the 
Options menu.

The Spell Check option is active by default, although you can disable 
it before running recognition.    Spell Check does not slow down recognition 
much, but it may not be useful if your documents are full of words and 
phrases that are spelled oddly.

If you want to scan and recognize a series of documents, you may 
want to turn the option off and perform a spell check later from within your 
word processing program.    Alternatively, you can leave Spell Check on and 
just click on the Save As button as soon as recognition is finished.    This 
way, you won't have to edit immediately, but you'll take advantage of the 
Spell Check feature.



The Adaptive Scan menu item 

Adaptive Scan uses all of the smart features in CuneiForm to give you
the best possible image.    Notice that when you select Adaptive Scan from 
the Options menu (<Alt> + O, then S), the word Smart appears in place of 
the brightness setting value in the status line.

The reason for this is that you cannot set Brightness for an adaptive 
scan.    Normally a document is scanned using a threshold value.    Everything
with a brightness below the value is black and everything with a brightness 
value above it is white.    With Adaptive Scan, each pixel is given a gray-
scale value ranging from 0 to 255, depending on its relative brightness.    
After the brightness values for all of the pixels have been determined, they 
are converted into a black and white image. 

Because it is a much more precise process, adaptive scanning is much 
slower than normal scanning.    While adaptive scanning definitely produces 
the best images, you probably won't need it for most documents.

Adaptive Scan does not initiate scanning. It only designates the type 
of scan to be performed.    You'll have to choose Scan & Recog, Scan & 
View or Batch scanning to start the scanner.



The Dot Matrix menu item 

If you need CuneiForm to recognize the fragmented printout from dot 
matrix printers, select Dot Matrix in the Options menu (<Alt> + O, then 
D).

It is best to leave this switch off when you're scanning regular 
materials.    Check the status line at the bottom of your screen to see if the 
option is turned on.    When you select Dot Matrix, the character string 
DOTs appears toward the right end of the status line.    You can also look at 
the Options menu to see if there's a checkmark to the left of the option.



The Page Orientation menu item 

Select Page Orientation from the Options menu to invoke the pull-
down menu and choose page orientation. 

This command lets you choose from four possible page orientations: 
Portrait, Landscape, Upside down and Flipped Landscape. When you 
choose an orientation other than Portrait, CuneiForm rotates all opened or 
scanned images. Note that the page orientation icon in the status line at the 
bottom of the screen reflects the orientation you've selected.

Page Orientation is necessary in batch processing because there is 
no way that you can intervene during processing to rotate images manually. 
(See also Rotate command).



The View Menu
The Main Menu's View option lets you choose the magnification level 

for images that appear in CuneiForm's Page View and Zoom View.    With 
your cursor, select View from the main menu (or type <Alt> + V).    The 
pull-down menu that appears offers the following options:

    Page View - displays image window on/off
        Fit In Window - view mode "Fit in window" for image window (Ctrl+F)
        Actual Size - 100% view for image window (Ctrl+A)
        200% - 200% view for image window (Ctrl+2)
        400% - 400% view for image window (Ctrl+4)
        Zoom View - displays zoom windowon/off (Ctrl+Z)
        Actual Size - 100% view for zoom window
        200% - 200% view for zoom window
        400% - 400% view for zoom window
    
Editors Settings - set point size and representation for badly 
recognized letters in the Edit Window



The Page View and Zoom View menu item groups

Page View refers to the scanned image that appears on the right side 
of your screen.    In the upper portion of the pull-down menu, four image size 
options are listed for Page View.    These are Fit In Window, Actual Size, 
200% and 400%.    Select one by clicking on it or by typing in its key 
combination (indicated to the right in the menu). The page image on the 
screen will appear at the magnification you selected, as will images you 
subsequently scan.

Below the Page View choices are three magnification choices for the 
Zoom View.    You can select Actual Size, 200%, or 400%.    The image in 
the Zoom Window will resize accordingly.

See also View pull_down menu



The Editor Settings menu item 

Select the last option in the View    menu (or type <Alt> + V, then S) 
to invoke the Editor Settings window. This option is available (unghosted) 
only after you run recognition on an image. 
 The first box in the Editor Settings window lets you specify a font size
for recognized text in the Edit Window. Choose between Small, Medium, 
and Large font sizes. Click inside the circle to the left of your selection and 
click OK (or click Cancel to revert to a Small font). The recognized text in 
the Edit Window will change size accordingly.

You can also choose a symbol for CuneiForm to assign to all 
unrecognized characters. Click on one of the five symbols available in the 
Choice field of the Unrecognized Character box. The selected symbol will
appear in the box adjacent to the Choice field and will replace all 
unrecognized characters in recognized text displayed it the Edit Window.



The Window Menu
Use CuneiForm's Window menu to choose the screen layout with 

which you're most comfortable working.    Click once on Window (or, <Alt> 
+ W) in the Main Menu to obtain the following options:

Split Horizontal
Split Vertical
Best View
View All
Customized Viewl
Save Customized Layout



The Split Horizontal menu item 

Click on Split Horizontal (^H) in the Window pull-down menu to 
divide the screen horizontally so that the Edit Window occupies the top 
portion of the screen and the Zoom Window, the bottom portion.



The Split Vertical menu item 

Click Split Vertical (^V) in the Window pull-down menu to get a 
vertically split screen displaying the Edit Window on the left and the Zoom 
Window on the right.



The Best View menu item 

The Best View option (^E) in the Window pull-down menu gives you 
access to CuneiForm's Control Panel in the upper left of the screen.    The 
Edit Window occupies the right half of the screen and the Zoom Window, 
the lower left quadrant.



The View All menu item 

Click View All (^3) in the Window pull-down menu to create a layout 
with the scanned image in the right half of the screen, the Edit Window in 
the upper left quadrant, and the Zoom Window in the lower left quadrant.



The Customized View and Save Customized Layout menu items 

Select Customized View (^C) in the Window pull-down menu to 
retrieve a customized screen layout you've saved using the Next menu 
option.    

You can use standard MS Windows methods to rearrange the screen 
layout as you like it.    Then click Save customized layout  to save it as the 
default layout.

Please note that if you save a customized layout that you've created 
within a maximized CuneiForm screen, your CuneiForm windows may overlap
the status line when you next open CuneiForm and the screen is not 
maximized.    This is because the program remembers a larger screen setup 
than the one you now have.    In this case, click on the upper right hand 
Windows button to maximize the CuneiForm screen.



The Help Menu
Three options are available in CuneiForm's Help pull-down menu. Click 

once on Help (or, <Alt> + H) in the Main Menu to access the following 
options:

Contents 
Topic Search 
About CuneiForm



The Contents menu item

Click on Contents in the Help pull-down menu (or type F1) to call up 
a list of CuneiForms basic features, including Commands, Main Screen, 
etc.    Click on one of the underlined features listed to see categories listed 
for that feature.    Next, click on a category of interest to obtain details.



The Topic Search menu item

Used    for more subject-specific help.    To activate Topic Search, place
the arrow cursor on a CuneiForm feature that you want to know more about 
and type ^F1.

For instance, if you want to quickly obtain information on the 
Recognize button in the Control Panel, place the cursor on the button and 
type ^F1.    Information on how to run character recognition will appear on 
the screen.

If you want details on Manual Layout, select this item in the Options 
pull-down menu and type ^F1.    A discussion of the Manual Layout option 
will appear on screen.    Similarly, you can get information on the status line 
as well as CuneiForm's main window.

See also Help pull-down menu.



The About CuneiForm menu item

Click on About CuneiForm at the bottom of the Help pull-down menu
 to view copyright, serial number and the name of the licensee.



Using the Keyboard 
Every command that can be executed using the mouse can also be 

executed using the keyboard. By holding the <Alt> key down and tapping 
the command letter, you activate that command. For instance, to pull down 
the File menu, you can click on the word File at the top of the screen, or you
can type <Alt> F. 

The <Alt> key also switches between keyboard commands and 
canceling keyboard commands. If you type <Alt> F and decide you don't 
want to use the File menu now, just tap <Alt> once. The File submenu will 
disappear.

If you have called up a menu by holding down the <Alt> key and 
typing any of the underlined letters in the Main Menu, such as the A for 
Actions and you see a letter underlined in the title of any of the commands 
on the pull-down menu, you can execute that command by simply typing 
that letter.

The Alt commands are:

F    = File Menu
E    = Edit Menu
A    = Actions Menu
O    = Options Menu
V    = View Menu
W = Window Menu
H    = Help Menu

At any time, you can use the control commands. They are executed by 
typing <Ctrl>    (^) plus a letter, as follows:

^O = pops up the Open Image submenu 
^L = restores the Last Image
^S = Scan & View
^B = pops up the Brightness submenu
^R = Recognize
^T = Define Template Zone
^D = Set Resolution

When you are in the Recognized Text Window <Tab> will move you
to the Next Suspect, and Shift + <Tab>, to a previous one.

During a Search, F3 will seek out the matching occurrence.
You can also use ^W to Validate Word and ^I to Invalidate Word
These Control commands affect the view on your screen:

^F = Fit in Window in the Image Window



^A = Actual Size in the Image Window
^2 = 200% magnification

^4 = 400% magnification
^Z = Zoom View

To choose the screen layout, use the following Control commands:

^H = Split Horizontal
^V = Split Vertical
^E = Best View
^3 = View All
^C = Customized View

^F1 Topic Search used    for more subject-specific help.



Using the Mouse
Your mouse can do most of the work in CuneiForm.    Use it to point to 

menus and buttons, to jump into dialog boxes and zoom across the screen.    
By holding down the left mouse button, you can drag the window's edges to 
resize the window.

To Define Template Zone, draw a rectangle around the text you want
by clicking on the Actions button, clicking the Define Template Zone 
button and moving your pointer to the Image Window.    Then, placing the 
pointer at one corner of the text you are interested in and holding the left 
mouse button down, drag a rectangle around the text you want.

When you use AutoBrightness, the mouse pointer cursor takes the form
of a light bulb as you select the area to be scanned for setting Brightness.

Using Manual Layout, the left mouse button lets you Merge, Extract
or Delete the boxes around blocks of text, as well as Split text boxes 
vertically or horizontally. You can also use it to outline an area to Zoom in on.



Messages

Group 1: Error messages from recognition engine:

"101. FileSys: Not enough memory for components file."
There is not enough computer memory to run recognition.

"102. FileSys: No place in the components file."
Image contains a lot of graphic components and does not fit internal 
memory requirements. Try to recognize part of this image.

"103. ExtrComp(an): Main number allocation fail."
Internal error. Probably your image file is damaged.

"104. ExtrComp(an): Unable to exclude large picture."
Internal error. Probably your image file is damaged.

"105. FileSys: No place in the roots file."
Image contains a lot of graphic components and does not fit internal 
memory requirements. Try to recognize part of this image.

"106. LinesForming: Not enough memory."
Image has very complicated layout. Try to recognize part of it.

"107. LinesForming: Unable to count page skew."
Almost empty page. Very small number of letters found.

"108. LinesForming: Empty page."
The page is blank.

"109. ExtrComp(mn): No memory for boxes."
Internal engine error. Keep image file and send it to CTC.

"110. FileSys: No place for strings."
Image has very complicated layout. Try to recognize part of it.

"111. FileSys: No strings have been found."
Almost empty page. No strings to recognize were found.

"112. Tools: No place in the kit."
Internal engine error. Keep image file and send it to CTC.

"113. Main: No memory for working area (1Mb)."
There is not enough computer memory to run recognition.



Group 2: Messages caused by image defects.

"201. ScanTiff: No image file."
Cannot open image file. If the image comes from the scanner it means 
the scanner is inactive. If the image comes from a file it means an error
in opening the file. It is probably caused by a limit on the number of 
opened files in CONFIG.SYS. Increase the number of files in 
CONFIG.SYS or close some background applications.

"202. ScanTiff: Incorrect image file format."
Image file does not have proper TIFF 5.0 format.

Group 4: Spelling checker error messages

"401. Spelling: cannot find vocabulary."
There are no vocabulary files in the directory from which CUNEIFORM 
was started. Check presence of CUNEI.EXE in other directories.

"403. Spelling: the page has been processed by speller."
Speller is running this particular page a second time. Mistake in 
interface or ED-file is corrupted. Save image file and send it to CTC.

"405. Spelling: ed-file is corrupted."
Internal recognition error occured. Save image file and send it to CTC.

Group 6. Save error massages in text format.

"602. TextSave: Write error."
Error during write to TEXT file.

"603. TestSave: Out of memory."
Internal error. Save ED-file and image file    and send them to CTC.

"604. TextSave: Cannot open temporary ED-file."
Error in opening temporary ED-file. You should probably increase the 
number of files in the CONFIG.SYS or close some background 
applications.

"606. Lineout: Read error in ED-file."
Error in reading temporary ED-file. Check your hard disk for available 
space and absence of defects.

"609. RTF: ED-file is corrupted."
Internal error message. Save ED-file and image file and send them to 
CTC.



"611. Lineout: Write error on ED-file."
Write error during temporary ED-file save. Check your hard disk for 
available space and absence of defects.



TIFF
TIFF (Tagged Image File Format) - the most popular format for image 

storing. Almost all scanner-support, fax and OCR software can write and read
files in TIFF format.

Uncompressed image files require about 1 megabyte per page while 
compressed files are much smaller. We recommend using TIFF Group 4 
because it provides the most compression.



ASCII
ASCII (American Standard Code for Information Interchange) - the 

simplest coding for text information without any formatting or fonts 
information.



Smart ASCII
Smart ASCII - modification of ASCII with some formatting information. 

It tries to retain the paragraph form of the original.



RTF
RTF (Rich Text Format) retains the original formatting information and 

can be utilized by many word processors almost as if you had produced it 
yourself.



CTC Native Format

CTC Native Format is the text format for debugging and 
troubleshooting purposes.



Suspect or suspected mistake

Suspect or suspected mistake is a badly recognized 
character.CuneiForm will highlight such characters for you in Edit Window 
to examine after running recognition on a document. If you turn Spell Check
on , CuneiForm will also highlight questionable words.




